Return to Hobie.com

Hobie Forums

It is currently Thu Sep 21, 2017 10:44 am

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Mon Sep 04, 2017 12:25 pm 
Offline
Site Rank - Deck Hand

Joined: Tue Jul 11, 2017 3:48 pm
Posts: 11
I've got a 2015 TI, purchased used so no warranty. One of my vantage seat back angle adjusters stopped working recently. I opened it up to see what was going on. There is a 1/4" shock cord inside that is supposed to be attached by a loop held together with a hog ring on the left side (as you are facing forward) and then around to a pulley on the right side and back down to a plastic ratchet strip. The loop on mine came undone and I'm not sure how I can repair it. The loop wraps around SS pin below the pulleys on the left side and is VERY hard to access. My only thought at this time is to drill a hole in adjustment mechanism and secure the end of the cord there by passing it through the hole and tying a stopper knot on the outside. Any other thoughts? Has anyone else had their seat adjusters quit working?


Top
 Profile  
 
PostPosted: Tue Sep 05, 2017 12:34 pm 
Offline
Site Admin

Joined: Tue May 27, 2003 12:44 pm
Posts: 11890
Location: Oceanside, California
The boat has a two year warranty. Have your dealer file a claim and they should be able to get this fixed for you.

_________________
Matt Miller
Director of Parts and Accessory Sales
Warranty and Technical Support
Hobie Cat USA


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
© Hobie Cat Company. All rights reserved.
Powered by phpBB® Forum Software © phpBB Group