Return to Hobie.com
Hobie Forums
It is currently Mon May 10, 2021 10:13 pm

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Fri Jul 17, 2020 3:32 pm 
Offline
Site Rank - Deck Hand

Joined: Fri Jul 17, 2020 3:22 pm
Posts: 1
I recently acquired a used mirage adventure. Launched it from the beach this morning and everything worked perfectly. Peddled past the breakers and sailed for an hour and a half in choppy seasd. When I launched it again this afternoon, BOTH peddle chains snapped just as I was heading out. The fins were in plenty of water and I wasn't peddling excessively hard. The drive is original (2012 I think). But is it unusual for this to happen? Might there be too much tension or some other issue to examine (the replacement cables are over $100 with shipping). I can't afford this kind of break very often.

I recognize that this issue has probably been discussed elsewhere, but I haven't had the time to scour the entirety of the site.

Any advice is most appreciated!

John


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: Google [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Jump to:  
© Hobie Cat Company. All rights reserved.
Powered by phpBB® Forum Software © phpBB Group