Return to Hobie.com

Hobie Forums

It is currently Tue Oct 23, 2018 11:57 am

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 11 posts ] 
Author Message
PostPosted: Fri Jul 15, 2016 3:06 pm 
Offline
Site Rank - Deck Hand

Joined: Sun Sep 23, 2012 5:24 am
Posts: 9
Location: Havre de Grace, Maryland
Has anyone had issue with cracks on both ends at the top of aluminum Xbar, (where aka slide and locks into). Does Hobie consider this as normal wear?
Two cracks (it actually split about 2 inches long on upper Xbar on left side, I removed right side rubber edge guard and notice 2 -1" cracks on right side.


Sailing upper chesapeake
RedRobin


Top
 Profile  
 
PostPosted: Fri Jul 15, 2016 4:18 pm 
Offline
Site Rank - Old Salt

Joined: Sat Nov 05, 2011 1:58 am
Posts: 2818
Location: Forster, NSW, Australia
Should not happen... see your dealer.

_________________
Tony Stott
2012 Tandem Island "SIC EM" with Hobie spinnaker and Hangkai outboard
only cool people follow the (non-magnetic) titanium weight-loss program! lol.)


Top
 Profile  
 
PostPosted: Fri Jul 15, 2016 7:45 pm 
Offline
Site Rank - Old Salt

Joined: Sat Jan 14, 2012 8:24 pm
Posts: 760
Location: Houston, TX
High risk issue. Definitely a dealer issue. Agree with Tony.

_________________
Greg

2016 AI - Spinn & Jib

“Out of sight of land the sailor feels safe. It is the beach that worries him.”
– Charles G. Davis

Image


Top
 Profile  
 
PostPosted: Sat Jul 16, 2016 11:10 am 
Offline
Site Rank - Deck Hand

Joined: Sun Sep 23, 2012 5:24 am
Posts: 9
Location: Havre de Grace, Maryland
Hi Guys,
Well I just checked my 2015 AI and the same thing, only one crack on right side.
Have to remove rubber cover to see cracks.

Anyone interested in photos you can go to, https://drive.google.com/folderview?id= ... sp=sharing


Hobie 2010 AI
Hobie 2013 TI
Hobie 2015 AI

RedRobin


Top
 Profile  
 
PostPosted: Sat Jul 16, 2016 11:34 am 
Offline
Site Rank - Old Salt

Joined: Thu Aug 07, 2014 10:40 am
Posts: 927
Location: Blacklick, Ohio
Jesus! Now I'm going to go check mine. I have noticed some extra play recently.

Sent from my SPH-L720T using Tapatalk

_________________
2015 Hobie Tandem Island Hibiscus
"Third Normal Form"

  • Trampolines
  • Hobie cover
  • Davis Spar Fly
  • Kayakbob's Sprayskirts
  • Spine Board Hakas


Top
 Profile  
 
PostPosted: Sat Jul 16, 2016 12:29 pm 
Offline
Site Rank - Admiral

Joined: Wed Aug 06, 2014 5:52 pm
Posts: 282
Location: North carolina
Can you guys share how to remove and reinstall the rubber. I'd like to do the same when I'm close to 2 years. Right now I can only notice slight play in that area in which I think is normal.


Top
 Profile  
 
PostPosted: Sun Jul 17, 2016 10:20 am 
Offline
Site Rank - Old Salt

Joined: Sat Jan 14, 2012 8:24 pm
Posts: 760
Location: Houston, TX
Will check mine for sure. Who would have thought.

_________________
Greg

2016 AI - Spinn & Jib

“Out of sight of land the sailor feels safe. It is the beach that worries him.”
– Charles G. Davis

Image


Top
 Profile  
 
PostPosted: Fri Jul 22, 2016 11:35 am 
Offline
Site Rank - Deck Hand

Joined: Sun Sep 23, 2012 5:24 am
Posts: 9
Location: Havre de Grace, Maryland
Just received message from my Hobie dealer, Hobie sending out replacement for both the TI and AI.


Top
 Profile  
 
PostPosted: Sun Jul 24, 2016 6:10 pm 
Offline
Site Rank - Old Salt

Joined: Thu Aug 07, 2014 10:40 am
Posts: 927
Location: Blacklick, Ohio
Checked mine out today. No cracks.

Sent from my SPH-L720T using Tapatalk

_________________
2015 Hobie Tandem Island Hibiscus
"Third Normal Form"

  • Trampolines
  • Hobie cover
  • Davis Spar Fly
  • Kayakbob's Sprayskirts
  • Spine Board Hakas


Top
 Profile  
 
PostPosted: Thu Sep 15, 2016 4:58 pm 
Offline
Site Rank - Deck Hand

Joined: Mon Apr 05, 2010 5:28 pm
Posts: 10
Location: 17003 Annville PA
Yes, 2 out of 4 of mine are cracked, new ones are on order! To replace them, the X-bar (Crossbar) must be removed to take the bottom very short screw off, then re-assemble! To me, it is normal wear item?

_________________
2005 AI Blue hull (yep, only one ever made!) Prototype!
2014 TI Red hull
2002 MacGregor 26X PowerSailor 50 HP on the transom!!!


Top
 Profile  
 
PostPosted: Wed Apr 05, 2017 10:01 pm 
Offline
Site Rank - Deck Hand

Joined: Mon Oct 31, 2016 7:47 pm
Posts: 2
I had the exact same problem in my 2013. It cracked and released mid-sail.

I had asked my the dealer (Maclean NSW who are great) to follow up with Hobie who said they would not cover it under warranty but that I could post the old Xbar in (presumably at my expense) to be assessed. I will now do that as this appears to be a relatively common occurrence.

Can anyone tell me of theirs was covered under warranty?

Many thanks


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
© Hobie Cat Company. All rights reserved.
Powered by phpBB® Forum Software © phpBB Group