Return to Hobie.com
Hobie Forums
It is currently Thu Nov 14, 2019 6:53 am

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sun Aug 20, 2017 9:15 am 
Offline
Site Rank - Deck Hand

Joined: Sun Aug 20, 2017 9:08 am
Posts: 5
I have a TAI. The rod that moves up and down to adjust the seat height at the front is stuck. The part that slices back and forth on the rod is frozen and I can't get them to move to unlatch the mechanism to adjust, any help?


Top
 Profile  
 
PostPosted: Sun Aug 20, 2017 10:38 pm 
Offline
Site Rank - Captain

Joined: Fri May 13, 2016 8:06 pm
Posts: 40
Location: Laem Sing, Chanthaburi, Thailand
Coyote wrote:
I have a TAI. The rod that moves up and down to adjust the seat height at the front is stuck. The part that slices back and forth on the rod is frozen and I can't get them to move to unlatch the mechanism to adjust, any help?


Coyote, I don't have a fix for you, but I had the same problem with the front seat on my TI. I took it to the Hobie dealer who took a look and found a broken spring in the rod mechanism. He said it was not fixable and has ordered an entire new rod as a warranty item. I'd recommend taking your yak to the dealer.

Cheers
John


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
© Hobie Cat Company. All rights reserved.
Powered by phpBB® Forum Software © phpBB Group