Return to

Hobie Forums

It is currently Sun Nov 19, 2017 1:11 pm

All times are UTC - 8 hours [ DST ]

Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Mon Dec 30, 2013 7:24 am 
Site Rank - Deck Hand

Joined: Mon Dec 30, 2013 7:06 am
Posts: 1
I have a new Hobie Evolve battery that won't take a charge anymore. I bought the Evolve system this past summer and have barely used it until now, on my trip to Florida. The problems initially started one morning after a day's use last week, when I didn't see the usual solid (not blinking) red light after charging the battery all night. There was no light at all, so I checked the power supply and it showed a green light - still getting power. I plugged in the throttle and it displayed only 90% charge. I used it that day, charged it again (the red light worked again), and it charged all the way to 100%. But after I used it the next day and tried to charge it overnight again, the battery showed no red light and now only 80% charge on the display. I used it down to 30% the next day, charged it overnight again and this time it didn't charge at all. Anyone with experience on this? I've emailed Torqueedo international and their on holidays 'til the new year.

PostPosted: Thu Jan 02, 2014 8:06 am 
Site Rank - Old Salt

Joined: Sun Jul 18, 2010 12:55 pm
Posts: 361
Call your Hobie Dealer ........ sounds like a bad battery or charger

PostPosted: Thu Jan 02, 2014 1:48 pm 
Site Rank - Old Salt

Joined: Sun Apr 20, 2008 6:18 am
Posts: 2677
Location: Sarasota,Key West FL
kiwi2 :
A really common mistake that a lot of people do is they put dielectric grease on all the pins and the plugs in their connectors to try and keep the water out. This is a bad mistake, that grease is an insulator and is not designed for this type of use (it even tells you on the label). That grease only works in high current/high voltage applications (like the starter in your car for example). There are a lot of low voltage signals that the controller has to detect to charge high tech batteries, and insulating grease on all the terminals kills all that.
It's at least worth mentioning, and checking out that all the terminals are making good contact, if it still doesn't work at least you know you eliminated the obvious.
Next step contact your dealer or Torqeedo.

hope this helps

PostPosted: Fri Jan 03, 2014 5:45 pm 
Site Rank - Captain

Joined: Sun Mar 11, 2012 7:14 am
Posts: 149
Location: Wilmington, NC

I take it there was no error code displayed or you would have mentioned it.

I had a E30 Communication Error that Torqeedo attributed to dielectric grease on the cable from the throttle display to the battery.
Of course, no dielectric grease was ever applied to the battery charger terminal on the battery or the charger connectors.

The Torqeedo rep in the US has been very helpful.

Let's us know the cause once resolved.

PA 14; 2012
Cape Fear River - NC

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 8 hours [ DST ]

Who is online

Users browsing this forum: No registered users and 3 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
© Hobie Cat Company. All rights reserved.
Powered by phpBB® Forum Software © phpBB Group