Return to Hobie.com
Hobie Forums
It is currently Tue Sep 17, 2019 12:34 am

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sun Jul 07, 2019 2:08 pm 
Offline
Site Rank - Deck Hand

Joined: Sun Jul 07, 2019 1:58 pm
Posts: 1
Location: Auburn, AL
Has anyone had issues installing the transducer through hull plug? I drilled the hole just above the scupper as shown in the video. However the plastic is very thick on one side of this hole and after about 1 turn of the nut clicks and jumps down a thread. I have tried several times and am certain it is not cross-threaded. It is a 2019 Compass.


Top
 Profile  
 
PostPosted: Mon Jul 08, 2019 10:31 pm 
Offline
Site Rank - Admiral

Joined: Sat Sep 12, 2009 1:24 pm
Posts: 179
wyattearp wrote:
Has anyone had issues installing the transducer through hull plug? I drilled the hole just above the scupper as shown in the video. However the plastic is very thick on one side of this hole and after about 1 turn of the nut clicks and jumps down a thread. I have tried several times and am certain it is not cross-threaded. It is a 2019 Compass.


It's a known problem, we had many Compass like that.

The hulls often have a bump there, the only way is to sand down.
You should rather use an electric sander believe me!

_________________
François - French Hobie fishing team - Outback 2019 papaya
ex: Revo 13 2007 - PA 14 2008 - PA 12 2009 - Outback 2011/2013/2015 - Compass 2017


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
© Hobie Cat Company. All rights reserved.
Powered by phpBB® Forum Software © phpBB Group